вторник, 15 апреля 2014 г.

Excell. Как в формуле указать сразу диапазон листов

  Появился у клиента вопрос. В Microsoft Excell в одной таблице 31 лист. На 30-и листах данные, а на 31-м надо просуммировать ячейки всех предыдущих листов. Человеку было лень вручную вводить формулу вида =Лист1!A1+Лист2!A1+...+Лист29!A1+Лист30!A1 И он спрашивал, можно ли в формуле указать диапазон листов, а не перечислять каждый лист. Чтоб было быстрее и короче.
  Помогла в решении этого вопроса как ни странно встроенная помощь моего Microsoft Excel 2013.

  Получилось сделать этой формулой =СУММ(Лист1:Лист30!A1) При этом в настройках Excell была снята галочка Стиль ссылок R1C1 Здесь просуммирована ячейка А1 с 1-го по 30-й лист. В координатах ячейки A1 , символ A должен быть английским. Русский он не понимает.
  Если надо в формуле применить и диапазон листов и диапазон ячеек, то она выглядит так =СУММ(Лист1:Лист30!A1:A2) Тут суммируются ячейки A1 и A2 в листах с 1-го по 30-й.