понедельник, 26 мая 2014 г.

IE11 постоянно требует обновить Яву

  В браузере открывается сайт. Он в свою очередь запускает Java - приложение, которое и делает всю работу.
  Недавно вместо запуска Java-приложения столо появляться окно такого содержания - "Внимание! Компания-разработчик данного програмного обеспечения прекратила техническую поддержку системы ХХХХХХ с версиями Sun Java Plugin ниже 1.5.0. Для нормальной дальнейшей работы Вам необходимо установить новую версию Sun Java Plugin старше 1.5.0 Рекомендуем установить версию Sun Java Plugin 1.6. Установить сейчас и продолжить работу?"
Сообщение с ошибкой


  Если нажать Да, появляется страница компании Oracle в которой я запутался и ничего не понял.
  Установка с сайта Java последней версии Java-машины проблему не исправило. Это окно ошибки по прежнему появлялось.
  Я не буду описывать тут все мои поиски, а сразу скажу что помогло.
  Как и в деле когда сайт требует более новую версию Internet Explorer, чем та которая существовует, помог пункт "Свойства браузера" \ "Параметры просмотра в режиме совместимости" моего Internet Explorer 11. Когда я добавил наш сайт в список сайтов, для которых выбран просмотр в режиме совместимости - все заработало. Java-скрипты начали запускаться.