среда, 14 февраля 2018 г.

Ошибка CGI/Carp в Apache


  Есть линуксовая машина с web-сервером Apache. При попытке открыть страницу на perl в браузере чисто.
  В логе ошибок апача error.log периодически появляется сообщение

[Mon Feb 12 13:22:18.943860 2018] [core:notice] [pid 846] AH00094: Command line: '/usr/sbin/apache2'
Can't locate CGI/Carp.pm in @INC (you may need to install the CGI::Carp module) (@INC contains: 
   А дальше идет длинный список путей.
  Перл требовал установить какой-то CGI::Carp модуль.
  Оказалось, что ему просто нужна библиотека libcgi-session-perl.   Команда "apt-get install libcgi-session-perl" и перегрузка апача нам помогли.